Need some help!
-> Problem/Tech forum

#1: Need some help! Author: phlem75Location: United States PostPosted: Fri Mar 20, 2009 3:32 am
    ----
First I want to to say greetings to all. I have a lasoya promaster all stock for now. My problem is that the marker leaked through the lpr and spun the lpr gauge past the readings. The marker airs up hpr is showing about 375 but bolt does not blow back. I'm thinking of pulling the lpr apart cleaning and resealing it and putting a new gauge on it. I was wondering what lube to go with for this type of marker and also if anyone else has had this issue. Any help would be appreciated.

#2: Re: Need some help! Author: SpitlebugLocation: Campbell River, B.C. PostPosted: Fri Mar 20, 2009 5:42 am
    ----
Use Dow 33. Also, you need to lower your HPR below 300 psi for the LPR to even work. The LPR is designed to shut off at 300psi. So I would suggest that a range of 200-220psi is where you want your HPR to be at.

#3: Re: Need some help! Author: phlem75Location: United States PostPosted: Fri Mar 20, 2009 2:10 pm
    ----
Thanks I will give that a try and see were it leads me. I will let you know how I end up.

#4: Re: Need some help! Author: phlem75Location: United States PostPosted: Sat Mar 21, 2009 12:04 am
    ----
Mad props spitlebug I got my marker running again it breaths. You know your **** thanks for the help I am going to hit up icd for a new gauge tho for it being spun. I set the marker acording to the online manual will the promaster get that out of wak from one day of play.

#5: Re: Need some help! Author: SpitlebugLocation: Campbell River, B.C. PostPosted: Sat Mar 21, 2009 1:02 am
    ----
I assume it will work fine if the ram is cycling. Just your gauge will need to be replaced.



-> Problem/Tech forum

All times are GMT - 7 Hours

Page 1 of 1